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INSTALLATION:

Installing from CD:
- Insert the QuickStart™ CD ROM into you CD ROM drive and double-click on the “SetUp” icon.
- Follow the instructions to install the software on your PC.

Installing from the Web:
- Go to www.analog.com/microconverter/quickstart.html and click on “Complete Software Package Download”.
- Save the “SetUp.exe” file on your PC’s hard drive.
- Double-click the “SetUp” icon to launch the software installation routine.
- Follow the instructions to install the software on your PC.

note: Though you can install the software onto any hard drive and into any directory you wish, for the purposes of
simplicity the rest of this document will assume that you’ve installed at the default location of C:\ADuC.

A successful installation will place the following files and directories on your hard drive:

This document presents a brief introduction to the use of following tools:
- MetaLink’s 8051 assmebler
- the ADuC downloader
- the ADuC debugger (both versions)
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THE METALINK ASSEMBLER:

1. In the ADuC directory, double-click on the ASM51 icon ( ).

2. In the DOS window that comes up, type the relative path of the assembly file you wish to assemble.
For example, if you wish to assemble the example file C:\ADuC812\code\blink.asm, simply type
“code\blink.asm” as shown below.

The assembler will display the text “ASSEMBLY COMPLETE, 0 ERRORS FOUND” indicating that it has
successfully assembled the file and has created the hex and list files (eg. blink.hex & blink.lst) along side
the assembly input file (eg. blink.asm).  If the assembler indicates assembly errors, you should view the list
file (eg. blink.lst) to examine the errors.  To view the list file, open it with notepad or any standard text editor.

note: If the assembler returns an error message indicating a failure to read drive A, or a fatal error opening a file
on the A drive, then it is most likely failing to find the MOD52 or MOD812 file referenced by the assembly
file.  Make sure both MOD52 and MOD812 (plus any other “include” files referenced in your assembly code)
are located in the ADuC root directory (where you clicked the ASM51 icon).

For additional details on the use of the MetaLink ASM51 assembler, please refer to the ASM51 users manual at
C:\ADuC\ASM51\ASM51.pdf.

                                                                                                                                                                                         
THE ADuC DOWNLOADER:

1. Verify the following link connections on your ADuC812 QuickStart development board:
LK3 - inserted
LK4 - position A inserted (closest to LEDs)
LK6 - position A inserted (closest to LEDs)

For details on link connection options, refer to the eval board user’s guide at
C:\ADuC\Documentation\EvalDocs\812pcb.pdf, or at www.analog.com/microconverter/evaluation_boards.html.

2. Power up your eval board using the provided power supply or a 9V battery (not both).

3. Connect the eval board to your PC’s COM1 serial port using the provided RS-232 cable.

4. Press the RESET button on your eval board.

5. On your PC, in the ADuC directory, double-click the DownLoad icon ( ).

6. In the window that comes up, type the relative path of the hex file you wish to download.
For example, to download the example file C:\ADuC812\code\blink.hex, simply type “code\blink.hex” as
shown below.

http://www.analog.com/microconverter
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The downloader will display the below information, indicating that the serial download was successful.

7. Remove LK3 from your board and press RESET.  The code will begin executing (as indicated by a blinking
LED with the example code blink.hex).

8. To perform additional downloads, re-insert LK3 and repeat steps 4 thru 7 above.

ADDITIONAL DOWNLOADER OPTIONS:

To make use of the additional downloader options, type any of the following switches immediately following
the file name (making sure to precede  each with a space):

/C:n - select the COM port (default is 1)
/F:n.n - select the target crystal frequency in MHz (default is 11.0592)
/R - run the program from the beginning
/R:xxxx - run the program from the specified hex start address

For example, the below text selects a download via COM2 to an ADuC812 running at a 16MHz clock speed
and sets the downloader to automatically run the program immediately after downloading.

note: The serial downloader can also be launched directly from a DOS prompt.  For example:
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THE ADuC DEBUGGER (Version 2): ….try this version first if you are unsure of your chip’s firmware revision.

1. Verify the following link connections on your ADuC812 QuickStart development board:
LK3 - inserted
LK4 - position A inserted (closest to LEDs)
LK6 - position A inserted (closest to LEDs)

For details on link connection options, refer to the eval board user’s guide at
C:\ADuC\Documentation\EvalDocs\812pcb.pdf, or at www.analog.com/microconverter/evaluation_boards.html.

2. Power up your eval board using the provided power supply or a 9V battery (not both).

3. Connect the eval board to your PC’s COM1 serial port using the provided RS-232 cable.

4. Press the RESET button on your eval board.

5. From your PC’s START menu, choose Programs/ADuC/DeBugV2.

6. Click “OK” to get past the opening dialogue box, and then follow the steps outlined in the session wizard.
When you get to the “Files” step, specify C:\ADuC\code\blink.lst, or click the “Browse” button and locate the
blink.lst file, and then click the “Next” button.  For all the remaining session wizard steps, simply click the
“Next” button to accept the default settings.  Click the “Finish” button at the final session wizard screen.

If you get the below message, close the program and skip to the “VERSION 1” section in later pages.

Otherwise, some information will flash on the screen and the bar at the bottom of the screen will change:

from

to .

This indicates that you have successfully established communication with the chip.  Also notice that the
kernel revision number (eg. “2.01 Aug 30 1999”) appears in the “Firmware” box of the “Session” window.

If you don’t see the above information, then click the reset target button ( ) on the toolbar.

At this stage, you should see two open windows within the ADuC application:  the “Session” window, and
the program listing window (labeled “Blink.lst”).  If you don’t see the program listing window, then select
“Program” from the “View” pull-down menu.

7. From the “View” pull-down menu, choose “Memory” / “SFRs”.  This brings up a third window allowing you to
view the contents of the on-chip special function registers (“SFRs”).  Position these three windows
(“Blink.lst”, “Session”, and “SFRs”) on the screen so you can view the contents of each.

http://www.analog.com/microconverter/evaluation_boards.html
http://www.analog.com/microconverter
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8. Click the download program button ( ) on the toolbar, or choose “Download Program” from the “Target”
pull-down menu.  This downloads the program to the chip.

9. In the program window (“Blink.lst”), double click on the line “BLINK:   CPL  LED” (line 26, address 0000).
This sets a breakpoint at this address.  Notice that the breakpoint is indicated by a large red dot to the left of
the line.

10. Press the run program button ( ) on the toolbar, or choose “Run downloaded Program” from the “Target”
pull-down menu.  This runs the program from the beginning.  You will see the following message indicating
that the chip has hit the breakpoint.

Press “OK”, and the debugger will upload information from the chip.

note: If you wish to change what is automatically uploaded from the chip, press the setup uploads button ( ) on
the toolbar, and select what you want to be automatically uploaded.

11. In the “SFRs” window, pan down until you see the line  for P3.  It indicates that the current value of port 3 is
FF hex.  Notice also that the red LED on your eval board is on.  The line of code that’s about to be executed
will complement bit 4 of P3, which controls the LED on the eval board.

note: To view SFR values in binary or decimal, simply right-click inside the SFRs window.

note: Values colored green in the SFR window (or any other memory window) indicate that the data accurately
represents the value currently on the chip.

http://www.analog.com/microconverter
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12. Click the resume button ( ) on the toolbar, or choose “Resume” from the “Target” pull-down menu.  Click
“OK” at each of the below dialogue boxes.

    

Notice that the red LED on your eval board has turned off, and the value of P3 in the “SFRs” window has
changed to EF hex.

note: You can turn off the above dialogue boxes in the “System settings” in the “Configure” pull-down menu.

13. You can resume again ( ), or step through the code using the single-step button ( ) on the toolbar, or
set additional breakpoints by double-clicking on other lines of code.  To clear a breakpoint, simply double-
click on the line again.

14. To save your session settings, click the save session button ( ) on the toolbar, or choose “Save” from the
“File” pull-down menu, and select the desired session file name and location.

15. To close the session, choose “Close” from the “File” pull-down menu.

16. To open a pre-existing session file, click the open session button ( ) on the toolbar, or choose “Open”
from the “File” pull-down menu, and select the file you wish to open.

For more information on the use of the version 2 debugger, use the “Help” options within the application.
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THE ADuC DEBUGGER (Version 1): ….this section is for use only with chips containing Version 1 firmware.

if you are unsure of your chip’s firmware revision, try Version 2 (above) first.

1. Verify the following link connections on your ADuC812 QuickStart development board:
LK3 - inserted
LK4 - position A inserted (closest to LEDs)
LK6 - position A inserted (closest to LEDs)

For details on link connection options, refer to the eval board user’s guide at
C:\ADuC\Documentation\EvalDocs\812pcb.pdf, or at www.analog.com/microconverter/evaluation_boards.html.

2. Power up your eval board using the provided power supply or a 9V battery (not both).

3. Connect the eval board to your PC’s COM1 serial port using the provided RS-232 cable.

4. Press the RESET button on your eval board.

5. From your PC’s START menu, choose Programs/ADuC/DeBugV1.

6. Click “OK” to get past the opening dialogue box, then click the new session button ( ) or choose “New”
from the “Session” pull-down menu.

7. In the “Configuration” window, click the “Comms” button and accept the default values by clicking “OK”.

8. Also in the “Configuration” window, click the “Files” button.  In the “Session Files” window that appears,
enter “C:\ADuC\code\blink.hex” on the “EXE” line, or click the browse button to find the blink.hex file.  On
the “LST” line, enter “C:\ADuC\code\blink.lst” or click the browse button to find the blink.lst file.

9. Press the reset button on the evaluation board.   Then click the reset target button ( ) on the toolbar, or
choose “Reset” from the “Target” pull-down menu.

A successful reset is indicated by the “Firmware” line in the Configuration window  updating to “ver 1.0 0krl”,
and a line at the bottom of the screen indicating “Target switched to kernel mode”.  If instead, you get a
“Failed to reset the target” message, then you may have a chip containing version 2 firmware and you
should try the version 2 steps outlined in previous pages.  But first double check your link configurations
and try steps 1 through 9 here again.

10. In the “Window” pull-down menu, choose “Program Listing” to view the list file (blink.lst) of the program
you’re debugging.  Also in the “Window” pull-down menu, choose “SFRs” to view the special function
registers window.  Finally, in the “Window” pull-down menu, choose “BreakPoints” to bring up the
breakpoints window.  Position these windows so that you can see the contents of each.

11. Click the download program button ( ) on the toolbar, or choose “Download Program” from the “Target”
pull-down menu.  A successful download is indicated by the text “Program downloaded OK” at the bottom of
the screen.

http://www.analog.com/microconverter/evaluation_boards.html
www.analog.com/microconverter
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12. Pan down in the “Program listing” window until you see the line “BLINK:   CPL  LED” (line 26, address 0000)
and double click on this line.  The below dialogue box will appear.  Click “Set Breakpoint”, and then click
“Close”.  Notice that the address “0000” now appears in the “Breakpoints” window.

13. Click the run program button ( ) on the toolbar, or select “Run from start” from the “Target” pull-down
menu.  Click “OK” in response to the below dialogue box.

The text “Data uploaded successfully” at the bottom of the screen indicates that data has been uploaded
from the chip to update the SFRs window on the debugger.  All SFR values colored green accurately reflect
what is currently on the chip.

note: If you wish to change the number of SFRs that are automatically uploaded, you can choose “Uploads” from
the “Setup” pull-down menu and select what you want to be automatically uploaded.

14. In the “SFRs” window, pan down until you see the line  for P3.  It indicates that the current value of port 3 is
FF hex (i.e. 255 dec or 11111111 bin).  Notice also that the red LED on your eval board is on.  The line of
code that’s about to be executed will complement bit 4 of P3, which controls the LED on the eval board.

http://www.analog.com/microconverter
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15. Click the resume button ( ) on the toolbar, or choose “Resume” from the “Target” pull-down menu.  Click
“OK” at each of the below dialogue boxes.

      

Notice that the red LED on your eval board has turned off, and the value of P3 in the “SFRs” window has
changed to EF hex.

note: You can turn off the above dialogue boxes in the “Display” settings in the “Setup” pull-down menu.

16. You can resume again ( ), or set additional breakpoints by double-clicking on other lines of code.  To
clear a breakpoint, simply double-click on the line again and choose “Clear breakpoint”.

17. To save your session settings, click the save session button ( ) on the toolbar, or choose “Save” from the
“Session” pull-down menu, and select the desired session file name and location.

18. To close the session, choose “Close” from the “Session” pull-down menu.

19. To open a pre-existing session file, click the open session button ( ) on the toolbar, or choose “Open”
from the “Session” pull-down menu, and select the session file you wish to open.

                                                                                                                                                                                         

Up to date revisions of this document and other MicroConverter documentation, plus free downloads of all the
latest revisions of the software described herein, are available at www.analog.com/microconverter along with
contact information for technical support inquiries.

http://www.analog.com/microconverter
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ANALOG DEVICES SOFTWARE LICENSE AGREEMENT

This is a legal document between you (either an individual or an authorized representative of a
legal entity) and Analog Devices, Inc. (ADI).  Read the following terms and conditions
carefully before opening the accompanying software packets.  They define your rights and
obligations with respect to the enclosed ADI software and documentation (SOFTWARE).  If you
do not agree to the terms of this agreement, promptly return the sealed software packet(s) and
accompanying documentation to the place you obtained them or to ADI. If the return is
postmarked, or is received, within thirty (30) days of shipment, charges for the software will be
removed from your bill.  OPENING THE SEALED SOFTWARE PACKET INDICATES YOUR

AGREEMENT WITH AND ACCEPTANCE OF THE FOLLOWING TERMS AND CONDITIONS.  AN

INDIVIDUAL WHO DOES NOT HAVE AUTHORITY TO BIND THE ENTITY USING THE SOFTWARE

SHOULD NOT OPEN THE SOFTWARE PACKET WITHOUT OBTAINING APPROVAL OF THIS

AGREEMENT FROM A PERSON HAVING SUCH AUTHORITY.

1) SOFTWARE LICENSE GRANT

A. You are granted a non-exclusive license to use this serialized copy of copyrighted
SOFTWARE, only in accordance with this license agreement.

2) YOUR OBLIGATIONS AND DUTIES

A. You may make up to two (2) copies to be used only for backup or archival purposes.  All
copyright notices and legends and this license agreement shall be reproduced on the
backup copies.

B. You may not disclose or transfer any portion of the SOFTWARE to any other party for
any reason.  Upon discontinuation of use of the SOFTWARE or termination of this
license, you agree to destroy all copies, including partial copies, of the SOFTWARE.

3) TERMS, TERMINATION/CANCELLATION

A. ADI may terminate this license upon your failure to comply with any of the terms and
conditions of this agreement.

4) LIMITED WARRANTY AND LIMITATIONS OF LIABILITY AND REMEDY

A. ADI warrants the SOFTWARE media against manufacturing defects for a period of
ninety (90) days from the date of receipt.  ADI will replace defective media at no charge
to you.  The SOFTWARE itself is otherwise provided to you on an “AS IS” basis.  ADI
does not provide any warranty or make any representation, either express or implied, that
the SOFTWARE meets your needs or expectations, that it will function as anticipated, or
that its use will not infringe on the intellectual property rights of any third party,
although, to the best of its knowledge ADI is not aware of any such IP rights.  You
assume the full responsibility for the selection, use and performance of the SOFTWARE.



WITH RESPECT TO THIS SOFTWARE, THE ABOVE LIMITED MEDIA
WARRANTY IS IN LIEU OF ALL OTHER WARRANTIES.  ADI MAKES NO
OTHER WARRANTY, EITHER EXPRESS OR IMPLIED, INCLUDING THE
IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A
PARTICULAR PURPOSE, AND SUCH WARRANTIES ARE EXPRESSLY
DISCLAIMED.

B. Replacement of defective media is your sole and exclusive remedy to any SOFTWARE
claims.  ADI is not liable nor responsible for any special, incidental, direct or
consequential damage, including but not limited to lost profits, downtime, or damages to
property, resulting from any cause whatsoever.

5. GENERAL

A. This agreement is the complete and exclusive statement of the SOFTWARE Agreement
between you and ADI and supersedes all prior oral and written communications,
agreements, representations, statements and undertakings with respect to the
SOFTWARE, including any terms and conditions on your purchase order.  No
modification, termination, extension, renewal or waiver of, nor addition to the terms and
conditions of this agreement shall be binding upon ADI unless specifically set forth in
writing, and signed by an authorized official of ADI.

B. Title to the SOFTWARE and all copies and portions thereof shall remain in the copyright
holder, and you only purchase the limited license set forth in this agreement.

C. You may neither assign any right or license granted under this agreement nor delegate
any obligation under this agreement.

D. This agreement shall be governed by the substantive laws of the Commonwealth of
Massachusetts, and you consent to the jurisdiction of the Courts of the Commonwealth of
Massachusetts for resolution of any dispute involving this agreement.

You acknowledge that you have read this agreement, that you understand it, that you agree
to be bound by its terms and conditions.


